Delayed Snowflake Queries

Incident Report for iSpot

Resolved

Earlier this morning we received alerts indicating a performance degradation event that involved queueing within Snowflake, which attributed to possible API and Dash data queries to be delayed. Originally, we associated the queueing to also be affecting the Dash analytics page as well; however, after much investigation, we have identified that there are two issues:

-The first issue involved a high amount of Snowflake API traffic which resulted in some data queries taking longer than expected or to possibly time out. This was identified to be caused by a single client that was producing high load via API against Snowflake. We started to remediate this; however, the client halted their high API traffic on their own and this issue was resolved around 10:00 AM PDT.

-The second issue is limited to internal users, or clients, that have numerous client accounts assigned that are experiencing latency within Dash. This is causing login delays, webpage delays, and overall latency within Dash. We have identified that approximately 1% of total users are impacted and given the scope of this issue we will be issuing a new Statuspage communication outlining the incident details.
Posted May 23, 2025 - 15:58 PDT

Update

We are continuing to investigate the issue with overall latency in the dash. Thank you for your patience.
Posted May 23, 2025 - 12:59 PDT

Investigating

We are currently investigating reports of slow load times in the dashboard. Some users may experience delays when accessing or interacting with dashboard data. Our engineering team is actively investigating the issue, and we will share updates as more information becomes available.
Posted May 23, 2025 - 08:37 PDT
This incident affected: Dashboard/Site Availability (iSpot Analytics, Creative Assessment).