We appreciate your patience. Normal operations have resumed and all impacted data is now available. Please reach out to customersupport@ispot.tv for any concerns or questions.
Posted Oct 23, 2025 - 16:01 PDT
Update
All backlog data processing is complete. Normal operations can be expected to resume at 9AM PST on 10/23.
Posted Oct 22, 2025 - 18:16 PDT
Monitoring
Normal data processing has resumed following the AWS outage. However, customers may continue to experience delays as we work through the data backlog caused by the disruption. We will provide another update once all processing has fully returned to normal.
Posted Oct 21, 2025 - 13:21 PDT
Update
We are still experiencing data delays due to the ongoing impact from the AWS outage on our data partners. Our teams are actively working to restore full data delivery. We will provide another update by 3:00 PM EST.
Posted Oct 21, 2025 - 10:20 PDT
Update
We have confirmed the below products and KPIs are impacted by the ongoing AWS outage. Data up to 10/19 will continue to be available, but forward processing is impacted. We'll follow up as more information becomes known.
Impacted Products/KPIs: TV Conversions UM Conversions UM Lift TVC Lift Tune-In Telecast Streaming Competitive Media Recommendation IDL Conversions Attention Analytics YouTube LinkedIn Out of Home (OOH) Region Level Impressions IULD cIULD Spend Outcomes At Scale
Posted Oct 20, 2025 - 10:24 PDT
Investigating
We’re experiencing service disruptions due to an ongoing AWS outage and are working closely with AWS to restore full functionality as quickly as possible. We will provide additional updates as more information and specific impact on our products becomes available. You can view the overall status and health of AWS services using the AWS Health dashboard https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 09:27 PDT
This incident affected: Dashboard/Site Availability (iSpot Analytics), SaaS Data Availability (Media Measurement, Unified Measurement, Tune-in Conversions), DaaS Data Availability (IULD, CIULD, Telecast Ratings), and Key KPIs (Linear Impressions, OTT Impresssions, Reach, Frequency, Attention, OTT Conversions, TV Conversions, Lift, Initial Spend, Final Spend).